import Foundation
let pattern = #"^(?!1?\d{10}@)[\w-]+(?:\.[\w-]+)*@[\w-]+(?:\.[\w-]+)*\.[A-Za-z]{2,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
howard.testman123@gmail.com
1234567890@gmail.com
18005567890@gmail.com
55555555555@gmail.com
321654575321@anything.org
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)