re = /^(?!1?\d{10}@)[\w-]+(?:\.[\w-]+)*@[\w-]+(?:\.[\w-]+)*\.[A-Za-z]{2,}$/m
str = 'howard.testman123@gmail.com
1234567890@gmail.com
18005567890@gmail.com
55555555555@gmail.com
321654575321@anything.org'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end