package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/guestAccounts/.{2,100}/somethingElse`)
var str = `/guestAccounts/c4c3b592-94ec-41dd-9cea-257875705799/somethingElse`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}