const regex = new RegExp('/guestAccounts/.{2,100}/somethingElse', '')
const str = `/guestAccounts/c4c3b592-94ec-41dd-9cea-257875705799/somethingElse`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}