import Foundation
let pattern = #"/guestAccounts/.{2,100}/somethingElse"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/guestAccounts/c4c3b592-94ec-41dd-9cea-257875705799/somethingElse"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}