re = /\/guestAccounts\/.{2,100}\/somethingElse/
str = '/guestAccounts/c4c3b592-94ec-41dd-9cea-257875705799/somethingElse'
# Print the match result
str.match(re) do |match|
puts match.to_s
end