package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.+\n)*.*?\bcat\b.*(?:\n.+)*`)
var str = `Paragraph 1 wepfowfpo
fww efwf
Paragraph 2 wefwf32321
!@d r33tcat54, 333!..
Paragraph 3 4t4t022
-\`121231ere3r3cat342232
$ 4t0g cat rdwd203
$$333
Paragraph 4 222cocdo3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}