import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.+\\n)*.*?\\bcat\\b.*(?:\\n.+)*";
final String string = "Paragraph 1 wepfowfpo\n"
+ "fww efwf\n\n"
+ "Paragraph 2 wefwf32321\n"
+ "!@d r33tcat54, 333!..\n\n"
+ "Paragraph 3 4t4t022\n"
+ "-`121231ere3r3cat342232\n"
+ "$ 4t0g cat rdwd203 \n"
+ "$$333\n\n"
+ "Paragraph 4 222cocdo3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}