using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=\s*((?:[^,""]|""\s*([^""]*?)\s?"")+?)(?=\s*,|$)";
string input = @"Digest realm = ""http-auth@example.org"",
qop= "" auth, auth-int "", algorithm = MD5 ,
nonce =""7ypf/xlj9XXwfDPEoM4URrv/xwf94BcCAzFZH4GiTo0v"" ,
opaque=""FQhe/qaU925kfnzjCev0ciny7QMkPqMAFRtzCUYo5tdS""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}