const regex = /=\s*((?:[^,"]|"\s*([^"]*?)\s?")+?)(?=\s*,|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=\\s*((?:[^,"]|"\\s*([^"]*?)\\s?")+?)(?=\\s*,|$)', 'g')
const str = `Digest realm = "http-auth@example.org",
qop= " auth, auth-int ", algorithm = MD5 ,
nonce ="7ypf/xlj9XXwfDPEoM4URrv/xwf94BcCAzFZH4GiTo0v" ,
opaque="FQhe/qaU925kfnzjCev0ciny7QMkPqMAFRtzCUYo5tdS"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}