re = /=\s*((?:[^,"]|"\s*([^"]*?)\s?")+?)(?=\s*,|$)/
str = 'Digest realm = "http-auth@example.org",
qop= " auth, auth-int ", algorithm = MD5 ,
nonce ="7ypf/xlj9XXwfDPEoM4URrv/xwf94BcCAzFZH4GiTo0v" ,
opaque="FQhe/qaU925kfnzjCev0ciny7QMkPqMAFRtzCUYo5tdS"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end