import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "=\\s*((?:[^,\"]|\"\\s*([^\"]*?)\\s?\")+?)(?=\\s*,|$)";
final String string = "Digest realm = \"http-auth@example.org\",\n"
+ "qop= \" auth, auth-int \", algorithm = MD5 ,\n"
+ "nonce =\"7ypf/xlj9XXwfDPEoM4URrv/xwf94BcCAzFZH4GiTo0v\" ,\n"
+ "opaque=\"FQhe/qaU925kfnzjCev0ciny7QMkPqMAFRtzCUYo5tdS\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}