using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\S),(?=\h*\b[^\W\d])";
string substitution = @"\n";
string input = @"va1, var2, aVar,var4, my_var55 DECIMAL(20,4),";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}