$re = '/(?<=\S),(?=\h*\b[^\W\d])/m';
$str = 'va1, var2, aVar,var4, my_var55 DECIMAL(20,4),';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;