using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:""\s*[:,]|\{)\s*""|\\""|""\s*[:}])(*SKIP)(*F)|""";
string input = @"{""key"":""val""ue"",""other"":""invalid ""quo""te""}
{""key"":""val""ue"",""other"":""invalid ""quo""te"",""hello"":{""world"":""hell""o""}}
{""key"":""va\""l""ue"",""other"":""invalid ""quo""te""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}