package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:"\s*[:,]|\{)\s*"|\\"|"\s*[:}])(*SKIP)(*F)|"`)
var str = `{"key":"val"ue","other":"invalid ""quo"te"}
{"key":"val"ue","other":"invalid ""quo"te","hello":{"world":"hell"o"}}
{"key":"va\"l"ue","other":"invalid ""quo"te"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}