re = /(?:(?:"\s*[:,]|\{)\s*"|\\"|"\s*[:}])(*SKIP)(*F)|"/
str = '{"key":"val"ue","other":"invalid ""quo"te"}
{"key":"val"ue","other":"invalid ""quo"te","hello":{"world":"hell"o"}}
{"key":"va\\"l"ue","other":"invalid ""quo"te"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end