$re = '/(?:(?:"\s*[:,]|\{)\s*"|\\\\"|"\s*[:}])(*SKIP)(*F)|"/';
$str = '{"key":"val"ue","other":"invalid ""quo"te"}
{"key":"val"ue","other":"invalid ""quo"te","hello":{"world":"hell"o"}}
{"key":"va\\"l"ue","other":"invalid ""quo"te"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);