package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\h]`)
var str = `The r-a-i-n i~n S@#p=ain s\t*ays m-a-i-n-l-y i<>n t;he p|lai5n.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}