re = /[^\h]/m
str = 'The r-a-i-n i~n S@#p=ain s\\t*ays m-a-i-n-l-y i<>n t;he p|lai5n.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end