$re = '/[^\h]/m';
$str = 'The r-a-i-n i~n S@#p=ain s\\t*ays m-a-i-n-l-y i<>n t;he p|lai5n.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);