// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\h]").unwrap();
let string = "The r-a-i-n i~n S@#p=ain s\\t*ays m-a-i-n-l-y i<>n t;he p|lai5n.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}