using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(2)|3)\d{3} \d{4} \d{4} \d{4}(?(1) \d)$";
string input = @"2123 1234 1234 1234 5
3123 1234 1234 1234
2234 1234 1234 1234
3234 1234 1234 1234 1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}