// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(2)|3)\d{3} \d{4} \d{4} \d{4}(?(1) \d)$").unwrap();
let string = "2123 1234 1234 1234 5
3123 1234 1234 1234
2234 1234 1234 1234
3234 1234 1234 1234 1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}