import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(2)|3)\\d{3} \\d{4} \\d{4} \\d{4}(?(1) \\d)$";
final String string = "2123 1234 1234 1234 5\n"
+ "3123 1234 1234 1234\n\n"
+ "2234 1234 1234 1234\n"
+ "3234 1234 1234 1234 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}