package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\[)|(\])`)
var str = `[doing, wing, ingot]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}