import re
regex = re.compile(r"(?:\[)|(\])")
test_str = "[doing, wing, ingot]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)