#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\"'])(?:(?=(\\?))\2.)*?\1|(\b\w*[-']\w*\b)|(\w*)\b(?:(?!AND|OR)\w)+\b"
Local $sString = "word1 AND word2 AND 'word3 word4' OR word5AND OR 'word6 OR word7'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")