$re = '/([\"\'])(?:(?=(\\\\?))\2.)*?\1|(\b\w*[-\']\w*\b)|(\w*)\b(?:(?!AND|OR)\w)+\b/m';
$str = 'word1 AND word2 AND \'word3 word4\' OR word5AND OR \'word6 OR word7\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);