re = /([\"'])(?:(?=(\\?))\2.)*?\1|(\b\w*[-']\w*\b)|(\w*)\b(?:(?!AND|OR)\w)+\b/m
str = 'word1 AND word2 AND \'word3 word4\' OR word5AND OR \'word6 OR word7\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end