import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\\"'])(?:(?=(\\\\?))\\2.)*?\\1|(\\b\\w*[-']\\w*\\b)|(\\w*)\\b(?:(?!AND|OR)\\w)+\\b";
final String string = "word1 AND word2 AND 'word3 word4' OR word5AND OR 'word6 OR word7'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}