using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p[^>]*>(.+?)<\/p>";
string input = @"<p style=""text-align: center;"">It is a long established fact that a reader will be distracted by the readable content of a page when looking at its layout</p>
<p style=""text-align: center;"">It is a long established fact that a reader will be
distracted by the readable <br />
content of a page when looking at its layou</p>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}