import re
regex = re.compile(r"<p[^>]*>(.+?)<\/p>", flags=re.IGNORECASE | re.DOTALL)
test_str = ("<p style=\"text-align: center;\">It is a long established fact that a reader will be distracted by the readable content of a page when looking at its layout</p>\n"
"<p style=\"text-align: center;\">It is a long established fact that a reader will be\n"
"distracted by the readable <br />\n"
"content of a page when looking at its layou</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")