re = /<p[^>]*>(.+?)<\/p>/i
str = '<p style="text-align: center;">It is a long established fact that a reader will be distracted by the readable content of a page when looking at its layout</p>
<p style="text-align: center;">It is a long established fact that a reader will be
distracted by the readable <br />
content of a page when looking at its layou</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end