import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"customer_id\":\"([^\"]+)\"";
final String string = "{\"param\":\"success\",\"value\":\"10\",\"level\":\"0\",\"error_code\":\"101\",\"customer_id\":\"5b0e9b23e423b0d33c9f7ddfd\", \"purchases\": \"13\", \"last_activity_ts\": \"123523465\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}