re = /"customer_id":"([^"]+)"/m
str = '{"param":"success","value":"10","level":"0","error_code":"101","customer_id":"5b0e9b23e423b0d33c9f7ddfd", "purchases": "13", "last_activity_ts": "123523465"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end