using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"peso\:(\s)?\d+(.|,)\d+(\s)?kg";
string input = @"Peso: 3.9 kg";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}