package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)peso\:(\s)?\d+(.|,)\d+(\s)?kg`)
var str = `Peso: 3.9 kg`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}