$re = '/peso\:(\s)?\d+(.|,)\d+(\s)?kg/i';
$str = 'Peso: 3.9 kg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);