const regex = /peso\:(\s)?\d+(.|,)\d+(\s)?kg/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('peso\\:(\\s)?\\d+(.|,)\\d+(\\s)?kg', 'i')
const str = `Peso: 3.9 kg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}