package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\|move\|p([12])a:\s+([^|]+)\|([^|]+)`)
var str = `|move|p2a: Urshifu|Wicked Blow|p1a: Clefable
|move|p1a: Clefable|Stealth Rock|p2a: Jirachi
|move|p2a: Jirachi|Stealth Rock|p1a: Slowbro
|move|p2a: Jirachi|U-turn|p1a: Slowbro
|move|p1a: Slowbro|Teleport|p1a: Slowbro
|move|p1a: Dragapult|Shadow Ball|p2a: Starmie
|move|p2a: Togekiss|Air Slash|p1a: Excadrill|[miss]
|move|p1a: Excadrill|Rapid Spin|p2a: Amoonguss
|move|p2a: Amoonguss|Spore|p1a: Tangrowth
|move|p1a: Tangrowth|Knock Off|p2a: Amoonguss
|move|p2a: Amoonguss|Sludge Bomb|p1a: Tangrowth
|move|p2a: Amoonguss|Spore|p1a: Excadrill
|move|p2a: Togekiss|Flamethrower|p1a: Excadrill
|move|p1a: Excadrill|Iron Head|p2a: Togekiss
|move|p2a: Cinderace|Pyro Ball|p1a: Slowbro
|move|p2a: Cinderace|U-turn|p1a: Slowbro
|move|p1a: Slowbro|Teleport|p1a: Slowbro
|move|p2a: Urshifu|U-turn|p1a: Clefable
|move|p1a: Clefable|Thunder Wave|p2a: Cinderace
|move|p2a: Cinderace|Pyro Ball|p1a: Slowbro
|move|p1a: Slowbro|Slack Off|p1a: Slowbro
|move|p2a: Cinderace|U-turn|p1a: Slowbro
|move|p1a: Slowbro|Teleport|p1a: Slowbro
|move|p1a: Crawdaunt|Crunch|p2a: Amoonguss
|move|p2a: Amoonguss|Giga Drain|p1a: Crawdaunt
|move|p1a: Crawdaunt|Crunch|p2a: Cinderace
|move|p2a: Urshifu|U-turn|p1a: Tangrowth
|move|p1a: Tangrowth|Earthquake|p2a: Amoonguss
|move|p2a: Amoonguss|Spore|p1a: Tangrowth
|move|p1a: Tangrowth|Earthquake|p2a: Amoonguss
|move|p2a: Amoonguss|Spore|p1a: Tangrowth
|move|p1a: Excadrill|Earthquake|p2a: Amoonguss
|move|p1a: Excadrill|Earthquake|p2a: Jirachi
|move|p2a: Urshifu|Wicked Blow|p1a: Excadrill
|move|p2a: Urshifu|Wicked Blow|p1a: Slowbro
|move|p2a: Urshifu|Wicked Blow|p1a: Clefable
|move|p1a: Clefable|Moonblast|p2a: Urshifu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}