use strict;
my $str = '|move|p2a: Urshifu|Wicked Blow|p1a: Clefable
|move|p1a: Clefable|Stealth Rock|p2a: Jirachi
|move|p2a: Jirachi|Stealth Rock|p1a: Slowbro
|move|p2a: Jirachi|U-turn|p1a: Slowbro
|move|p1a: Slowbro|Teleport|p1a: Slowbro
|move|p1a: Dragapult|Shadow Ball|p2a: Starmie
|move|p2a: Togekiss|Air Slash|p1a: Excadrill|[miss]
|move|p1a: Excadrill|Rapid Spin|p2a: Amoonguss
|move|p2a: Amoonguss|Spore|p1a: Tangrowth
|move|p1a: Tangrowth|Knock Off|p2a: Amoonguss
|move|p2a: Amoonguss|Sludge Bomb|p1a: Tangrowth
|move|p2a: Amoonguss|Spore|p1a: Excadrill
|move|p2a: Togekiss|Flamethrower|p1a: Excadrill
|move|p1a: Excadrill|Iron Head|p2a: Togekiss
|move|p2a: Cinderace|Pyro Ball|p1a: Slowbro
|move|p2a: Cinderace|U-turn|p1a: Slowbro
|move|p1a: Slowbro|Teleport|p1a: Slowbro
|move|p2a: Urshifu|U-turn|p1a: Clefable
|move|p1a: Clefable|Thunder Wave|p2a: Cinderace
|move|p2a: Cinderace|Pyro Ball|p1a: Slowbro
|move|p1a: Slowbro|Slack Off|p1a: Slowbro
|move|p2a: Cinderace|U-turn|p1a: Slowbro
|move|p1a: Slowbro|Teleport|p1a: Slowbro
|move|p1a: Crawdaunt|Crunch|p2a: Amoonguss
|move|p2a: Amoonguss|Giga Drain|p1a: Crawdaunt
|move|p1a: Crawdaunt|Crunch|p2a: Cinderace
|move|p2a: Urshifu|U-turn|p1a: Tangrowth
|move|p1a: Tangrowth|Earthquake|p2a: Amoonguss
|move|p2a: Amoonguss|Spore|p1a: Tangrowth
|move|p1a: Tangrowth|Earthquake|p2a: Amoonguss
|move|p2a: Amoonguss|Spore|p1a: Tangrowth
|move|p1a: Excadrill|Earthquake|p2a: Amoonguss
|move|p1a: Excadrill|Earthquake|p2a: Jirachi
|move|p2a: Urshifu|Wicked Blow|p1a: Excadrill
|move|p2a: Urshifu|Wicked Blow|p1a: Slowbro
|move|p2a: Urshifu|Wicked Blow|p1a: Clefable
|move|p1a: Clefable|Moonblast|p2a: Urshifu';
my $regex = qr/\|move\|p([12])a:\s+([^|]+)\|([^|]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}