import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|move\\|p([12])a:\\s+([^|]+)\\|([^|]+)";
final String string = "|move|p2a: Urshifu|Wicked Blow|p1a: Clefable\n"
+ "|move|p1a: Clefable|Stealth Rock|p2a: Jirachi\n"
+ "|move|p2a: Jirachi|Stealth Rock|p1a: Slowbro\n"
+ "|move|p2a: Jirachi|U-turn|p1a: Slowbro\n"
+ "|move|p1a: Slowbro|Teleport|p1a: Slowbro\n"
+ "|move|p1a: Dragapult|Shadow Ball|p2a: Starmie\n"
+ "|move|p2a: Togekiss|Air Slash|p1a: Excadrill|[miss]\n"
+ "|move|p1a: Excadrill|Rapid Spin|p2a: Amoonguss\n"
+ "|move|p2a: Amoonguss|Spore|p1a: Tangrowth\n"
+ "|move|p1a: Tangrowth|Knock Off|p2a: Amoonguss\n"
+ "|move|p2a: Amoonguss|Sludge Bomb|p1a: Tangrowth\n"
+ "|move|p2a: Amoonguss|Spore|p1a: Excadrill\n"
+ "|move|p2a: Togekiss|Flamethrower|p1a: Excadrill\n"
+ "|move|p1a: Excadrill|Iron Head|p2a: Togekiss\n"
+ "|move|p2a: Cinderace|Pyro Ball|p1a: Slowbro\n"
+ "|move|p2a: Cinderace|U-turn|p1a: Slowbro\n"
+ "|move|p1a: Slowbro|Teleport|p1a: Slowbro\n"
+ "|move|p2a: Urshifu|U-turn|p1a: Clefable\n"
+ "|move|p1a: Clefable|Thunder Wave|p2a: Cinderace\n"
+ "|move|p2a: Cinderace|Pyro Ball|p1a: Slowbro\n"
+ "|move|p1a: Slowbro|Slack Off|p1a: Slowbro\n"
+ "|move|p2a: Cinderace|U-turn|p1a: Slowbro\n"
+ "|move|p1a: Slowbro|Teleport|p1a: Slowbro\n"
+ "|move|p1a: Crawdaunt|Crunch|p2a: Amoonguss\n"
+ "|move|p2a: Amoonguss|Giga Drain|p1a: Crawdaunt\n"
+ "|move|p1a: Crawdaunt|Crunch|p2a: Cinderace\n"
+ "|move|p2a: Urshifu|U-turn|p1a: Tangrowth\n"
+ "|move|p1a: Tangrowth|Earthquake|p2a: Amoonguss\n"
+ "|move|p2a: Amoonguss|Spore|p1a: Tangrowth\n"
+ "|move|p1a: Tangrowth|Earthquake|p2a: Amoonguss\n"
+ "|move|p2a: Amoonguss|Spore|p1a: Tangrowth\n"
+ "|move|p1a: Excadrill|Earthquake|p2a: Amoonguss\n"
+ "|move|p1a: Excadrill|Earthquake|p2a: Jirachi\n"
+ "|move|p2a: Urshifu|Wicked Blow|p1a: Excadrill\n"
+ "|move|p2a: Urshifu|Wicked Blow|p1a: Slowbro\n"
+ "|move|p2a: Urshifu|Wicked Blow|p1a: Clefable\n"
+ "|move|p1a: Clefable|Moonblast|p2a: Urshifu";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}