#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^,()\s][^,\n]*)\s\("
Local $sString = "Topic 1 (Speaker 1)" & @CRLF & _
"" & @CRLF & _
"Event_type_1 - , Topic 2 (Speaker 2)" & @CRLF & _
"" & @CRLF & _
"Event_type_2 - , Topic 3 (Speaker 3)" & @CRLF & _
"" & @CRLF & _
"Topic 4 (subtopic 1) (Speaker 1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")