package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^,()\s][^,\n]*)\s\(`)
var str = `Topic 1 (Speaker 1)
Event_type_1 - , Topic 2 (Speaker 2)
Event_type_2 - , Topic 3 (Speaker 3)
Topic 4 (subtopic 1) (Speaker 1)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}