re = /([^,()\s][^,\n]*)\s\(/m
str = 'Topic 1 (Speaker 1)
Event_type_1 - , Topic 2 (Speaker 2)
Event_type_2 - , Topic 3 (Speaker 3)
Topic 4 (subtopic 1) (Speaker 1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end