using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\-?\d+(\.\d+)?$";
string input = @"1
2
3
4
5
6
1000
100.123123123123
0000
abc
foo
foo123
123.
.321
0.123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}