$re = '/^\-?\d+(\.\d+)?$/m';
$str = '1
2
3
4
5
6
1000
100.123123123123
0000
abc
foo
foo123
123.
.321
0.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);