re = /^\-?\d+(\.\d+)?$/m
str = '1
2
3
4
5
6
1000
100.123123123123
0000
abc
foo
foo123
123.
.321
0.123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end