package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\-?\d+(\.\d+)?$`)
var str = `1
2
3
4
5
6
1000
100.123123123123
0000
abc
foo
foo123
123.
.321
0.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}